View Issue Details

IDProjectCategoryLast Update
0023507AI War 2Bug - GameplayAug 7, 2020 8:04 am
Reportercrawlers Assigned ToBadgerBadger  
Severitymajor 
Status requires feedbackResolutionopen 
Product Version2.115 Imperial Summons 
Summary0023507: Regenerator golem + stacks is buggy
DescriptionWhen there are enough units present to where they begin to stack up and the regenerator golem is present, the units build up to far higher quantities than should be possible (like 500 eyebots). It seems to be around the unit limit multiplied by the stack size. See the battle at Tyros.
TagsNo tags attached.

Activities

crawlers

Aug 5, 2020 4:45 pm

reporter  

5_3_regnerator.save (1,668,084 bytes)

crawlers

Aug 5, 2020 4:54 pm

reporter   ~0057959

Perhaps that battle isn't a good example of the bug in progress, but it was a result of it. Perhaps coarse processing in places the player isn't looking at has something to do with it - will see if I get a better example of the issue.

crawlers

Aug 6, 2020 10:15 pm

reporter   ~0057970

I think the bug happens when the regenerator golem drops below 10% hp, not in offscreen battles - I saw it continue to revive units even after that. If I can get a decent save of this I will try to upload it.

BadgerBadger

Aug 7, 2020 2:04 am

manager   ~0057974

I've put in a potential fix for this for the next patch; let me know if it can still be recreated

crawlers

Aug 7, 2020 8:04 am

reporter   ~0057979

Alright, I will let you know if I notice it again.

Issue History

Date Modified Username Field Change
Aug 5, 2020 4:45 pm crawlers New Issue
Aug 5, 2020 4:45 pm crawlers File Added: 5_3_regnerator.save
Aug 5, 2020 4:45 pm crawlers File Added: 5_3_regnerator.savemet
Aug 5, 2020 4:54 pm crawlers Note Added: 0057959
Aug 6, 2020 10:15 pm crawlers Note Added: 0057970
Aug 7, 2020 2:04 am BadgerBadger Note Added: 0057974
Aug 7, 2020 2:04 am BadgerBadger Assigned To => BadgerBadger
Aug 7, 2020 2:04 am BadgerBadger Status new => requires feedback
Aug 7, 2020 8:04 am crawlers Note Added: 0057979

Debug Log

Number Execution time Caller Event
PLUGIN-10SMFAuth SMFAuth.php:55 SMFAuthPlugin->auto_login()SMFAuth Initializing
PLUGIN-20SMFAuth SMFAuth.php:59 SMFAuthPlugin->auto_login()SMF Settings loaded from /home/arcengames/public_html/forums
PLUGIN-30SMFAuth SMFAuth.php:147 SMFAuthPlugin->decodeCookie()Cookie doesn't exist! Is the user logged into the forums?